• Este sitio usa cookies. Al continuar usando este sitio, estás aceptando nuestro uso de cookies. Más información.

AutoCAD Aristas en superficies curvas en 3D

#1
hola!!!

tengo un 3d hecho en autocad y quiero imprimirlo con líneas ocultas, pero en todas las superficies curvas, pilares cilíndricos... aparecen unas aristas...

¿hay alguna manera de que desaparezcan?

he leído en un mensaje que se comentaba el comando resvista... pero a mi no me ha servido de nada...
tal vez no lo esté aplicando bien??

alguna solución please!
 
#2
veo que ya le había pasado a alguien... es que antes no he buscado lo suficiente...
pero este post se quedó sin resolver...
a mi lo de dispsilh tampoco me funciona...
 
#4
Esas superficies curvas ¿como han sido generadas?
Si se han generado por extrusion de una polilínea o un arco o un círculo no hay solución.
Si usas sólidos creo que se puede controlar la visibilidad de las líneas esas (hablo de memoria, hace mucho tiempo que no trabajo el AutoCAD).

Saludos.
 
#5
Prueba a aumentar el valor de las variables: surfu, surfv, surftab1 y surftab 2.

he aumentado esas variables hasta el máximo y no noto ningún cambio...
¿para qué se supone que son?

de todas maneras, los elementos que me dan problemas son sólidos 3d generados a partir de la extrusión de polilíneas en unos casos y de círculos en otros... así que como dice Vorpal tal vez no tenga solución...
pues vaya...

he probado a generar los elementos como sólidos y siguen apareciendo las líneas... ¿cómo es eso de controlar la visibilidad que comentas?

gracias
 
#6
En versiones más antiguas habia una varible llamada dispsilh que controlaba esa visualización despues del oculta, pero creo recordar que solo actuaba en sólidos.
 
#7
no se... me da que para mi caso no sirve...

yo tengo unos cilindros... y no noto que cambie nada... he dibujado al lado un toroide y ahí si parece que cambia algo al modificar dispsilh de 0 a 1...
 
#9
lo que pretendo hacer es un 3d pero no del tipo fotorealístico... vamos que no le voy a poner materiales ni nada... quiero que tenga un aspecto tipo cómic... no se si me explico...

pero claro, al imprimir el dibujo con aristas ocultas... las líneas que me aparecen en las superficies curvas (que tengo unas cuantas) y en todos los pilares cilíndricos me chafan el dibujo...

entonces se me ha ocurrido, (igual es una burrada), que en 3d studio tal vez haya alguna manera de hacer esto... pero ando enredando y no consigo nada... (hace bastante que no lo manejo y el que tengo ahora está todo en inglés...)...

help!
 
#11
bueno... es sólo un trocito del dibujo pero ahí se ve el problema tanto en una superficie curva como en los pilares...

 
#12
Acabo de reproducir el problema y a mí me funciona perfectamente.
Dispsilh=0: sí se ven las aristas.
Dispsilh=1: no se ven las aristas.
Tal vez digo una tontería, pero después de poner dispsilh a 1 hay que volver a ejecutar el comando oculta.
 
#13
vaya... y a mi por qué no me funciona???
yo lo sigo viendo igual aun ejecutando de nuevo el comando oculta...

con qué versión de autocad has hecho la prueba??
 
#14
no tengo mucha idea pero...
podría tener algo que ver con los parámetros que tengo establecidos dentro de:

opciones_sistema_visualización actual de gráfico 3d_propiedades

igual no tiene nada que ver pero me podriais decir que casillas tenéis activadas???

gracias
 
#15
Uso ACAD 2007.
En estos casos, lo que suelo hacer el buscar en el índice de la ayuda una orden relacionada, como puede ser en este caso dispsilh. Se abre a la derecha el contenido de la pestaña Comandos. Paso a la pestaña procedimientos o conceptos y vuelvo a comandos. Salen entonces un montón de variables del sistema. Cojo aire, cuento hasta diez y a probar.
 
#16
no te creas que no he entrado eh???

pero lo intentaremos de nuevo... lo de procedimientos sí es cierto que no lo he mirado...

1,2,3,4....10....allá voy...
 
#17
me rindo...

no puedo dejar de ver los sólidos triangulados...

con resvista y facetres controlo en número de triangulaciones... pero no hay manera de que estas no aparezcan...
a mí dispsilh no me funciona......:(
 
#20
pues quizás vaya a ser cuestión de la versión...

ayer abrí el archivo en la versión 2007 y problema solucionado...

no sé por qué no me funcionará la orden dispsilh en la 2006... igual después de andar cambiando tantos parámetros lo volví loco...

muchas gracias