Excel: promedio de un rango de celdas

Hola,
tengo que hacer el promedio de un rango de celdas (valores de 1 a 5), lo que quiero es que haga el promedio únicamente cuando todos los datos del rango estén cubiertos, he utilizado

=SI(D8:D15 >1;PROMEDIO(D8:D15);"media")

(lo de media es por poner algo)
Pero realiza el promedio en cuanto introduzco el primer valor aún con el resto en blanco, ¿alguien sabe cómo puedo hacer esto?
Gracias.
 

bicilindro

Titanio
Deberías usar la función "ESBLANCO" para saber si la celda está en blanco.
Podría anidar varios "SI" o utilizar un variable auxiliar.
Ejemplo"
SI celda 1 ESBLANCO
Y SI celda 2 ESBLANCO
Y SI celda N ESBLANCO
ENTONCES
PROMEDIO ( 1...N)
 

wenner

Bronce
Promedio de las celdas de un rango (denominado RangoCeldas) no vacias:

=SUMA(RangoCeldas)/(CONTAR(RangoCeldas)-CONTAR.BLANCO(RangoCeldas))


Promedio de las celdas de un rango (denominado RangoCeldas) de un valor mayor o igual a 0:

=SUMA(RangoCeldas)/CONTAR.SI(RangoCeldas;">0")

Saludos.
 

wenner

Bronce
Ya nos contarás si era lo que estabas buscando.
 
Arriba