BricsCAD Nueva versión de BricsCAD Linux Beta: 10.4.12

Iñaco

Plata
Pensaba que se irían de vacaciones sin sacar una nueva versión, pero no. Ya tenemos juguete nuevo para agosto :D

Un saludo.
 

random

Plata
¡Ya empezamos!:

known issues:
- Installation issues on 64 bit. It is possible to run Bricscad (Linux) on a 64 bit system. However, the Bricscad (Linux) installers do not automatically add all required 32 bit libraries. Additional manual setup is needed.


A ver si me entero de la instalación (en Linux en general y de Bricscad en particular) y le echamos un ojo de una vez.

¿No decían que sacaban la versión final en julio?
 

Iñaco

Plata
random, te lo están poniendo difícil :D.

Creo que simplemente hay que resolver las dependencias. No tengo la versión 64 bits y no te puedo decir cuáles son las que faltan. Lo consultaré en el foro de Bricsys.

Prueba a desempaquetar a mano:

sudo dpkg-deb -X [B](ruta donde hayas guardado el paquete deb)[/B]/BricscadClassic-V10.4.12-1-en_US.deb /

Ejecuta la aplicación mediante doble click en el archivo bricscad.sh.

Los de Bricsys llevan algo de retraso. Supongo que hacia finales de septiembre saldrá una versión RC y en octubre sacarán la versión comercial. O eso espero.

Un saludo.
 

random

Plata
random, te lo están poniendo difícil :D.

Si, yo pensaba que con Ubuntu se iban a resolver todos mis problemas vitales :D

Creo que simplemente hay que resolver las dependencias. No tengo la versión 64 bits y no te puedo decir cuáles son las que faltan. Lo consultaré en el foro de Bricsys.

Primero tendré que enterarme de qué son las dependencias... Tranquilo que ya lo investigo yo.

Prueba a desempaquetar a mano:

sudo dpkg-deb -X [B](ruta donde hayas guardado el paquete deb)[/B]/BricscadClassic-V10.4.12-1-en_US.deb /

Ejecuta la aplicación mediante doble click en el archivo bricscad.sh.

Los de Bricsys llevan algo de retraso. Supongo que hacia finales de septiembre saldrá una versión RC y en octubre sacarán la versión comercial. O eso espero.

Mejor, porque ahora estoy con Inkscape y Gimp. Para entonces lo habré podido instalar y probar.


Gracias.

Un saludo.
 

Iñaco

Plata
Pequeña guía para solucionar problemas de instalación de Bricscad en sistemas 64 bits, publicada en el foro de Bricsys:

  • Failed dependencies:
    • libexpat.so.1 is needed by bricscadv10-10.4.9-1.i386
    • libgcc_s.so.1 is needed by bricscadv10-10.4.9-1.i386
    • libgcc_s.so.1(GCC_3.0) is needed by bricscadv10-10.4.9-1.i386
    • libjpeg.so.62 is needed by bricscadv10-10.4.9-1.i386
    • libpng12.so.0 is needed by bricscadv10-10.4.9-1.i386
    • libstdc++.so.6 is needed by bricscadv10-10.4.9-1.i386
    • libstdc++.so.6(CXXABI_1.3) is needed by bricscadv10-10.4.9-1.i386
    • libstdc++.so.6(GLIBCXX_3.4) is needed by bricscadv10-10.4.9-1.i386
    • libz.so.1 is needed by bricscadv10-10.4.9-1.i386
SOLUTION: zypper install libexpat1-32bit libgcc44-32bit libjpeg-32bit libpng12-0-32bit libstdc++44-32bit
  • /opt/bricsys/bricscad/v10/bricscad: error while loading shared libraries: libfontconfig.so.1: cannot open shared object file: No such file or directory
SOLUTION: zypper install libqt4-x11-32bit
  • /opt/bricsys/bricscad/v10/bricscad: error while loading shared libraries: libcups.so.2: cannot open shared object file: No such file or directory
SOLUTION: zypper install cups-libs-32bit
  • /opt/bricsys/bricscad/v10/bricscad: error while loading shared libraries: libgtk-x11-2.0.so.0: cannot open shared object file: No such file or directory
SOLUTION: zypper install gtk2-32bit
  • /opt/bricsys/bricscad/v10/bricscad: error while loading shared libraries: libfreetype.so.6: cannot open shared object file: No such file or directory
SOLUTION: zypper install freetype2-32bit
  • in case there is a problem with fonts (each character is displayed as a rectangle): zypper remove cairo-32bit; zypper install gtk2-engine-murrine-32bit gtk2-engines-32bit librsvg-32bit pango-32bit qtcurve-gtk2-32bit
Vaya, vaya, Bricscad utiliza engine-murrine, ahora entiendo por qué va tan bien con elementary.

Descripción de los pasos a realizar para ejecutar Bricscad en Fedora 64 bit, corriendo con KDE:

  • Package BricscadClassic?-V10.4.9-1-en_US.rpm is not signed
SOLUTION: edit /etc/yum.conf and change gpgcheck from 1 to 0
  • opt/bricsys/bricscad/v10/bricscad: error while loading shared libraries: libfontconfig.so.1: cannot open shared object file: No such file or directory
SOLUTION: yum install qt-x11.i686
  • /opt/bricsys/bricscad/v10/bricscad: error while loading shared libraries: libgtk-x11-2.0.so.0: cannot open shared object file: No such file or directory
SOLUTION: yum install gtk2.i686
  • /opt/bricsys/bricscad/v10/bricscad: error while loading shared libraries: libfreetype.so.6: cannot open shared object file: No such file or directory
SOLUTION: yum install freetype.i686

Un saludo.
 

random

Plata
Gracias, iñaco.

Veo que yum es un programa para instalar dependencias, pero, ¿zypper no es un programa de OpenSuse?
 

Iñaco

Plata
Sí. Para Ubuntu utiliza apt-get y dpkg. Nunca he comprobado si es posible instalar zypper en Ubuntu...
 
Arriba